วันจันทร์ที่ 31 ตุลาคม พ.ศ. 2559

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:11:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

[computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] [computer] Re: [sage-devel] sage 7.4 does not build on Ubuntu 16.10

I tried to install sage-7.4 on a clean new Ubuntu:16.10 docker
container (on 64-bit x68 intel). It fails trying to building GCC with

...
gcc-4.9.3.p1] (cd
'/home/w/sage-7.4/local/var/tmp/sage/build/gcc-4.9.3.p1' &&
'/home/w/sage-7.4/sage' --sh)
[gcc-4.9.3.p1] When you are done debugging, you can type "exit" to
leave the subshell.
[gcc-4.9.3.p1] ************************************************************************
Makefile:1725: recipe for target
'/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1' failed
make[2]: *** [/home/w/sage-7.4/local/var/lib/sage/installed/gcc-4.9.3.p1]
Error 1
make[2]: Leaving directory '/home/w/sage-7.4/build/make'
Makefile:891: recipe for target 'all-toolchain' failed
make[1]: *** [all-toolchain] Error 2
make[1]: Leaving directory '/home/w/sage-7.4/build/make'

real 12m18.858s
user 8m6.992s
sys 2m15.888s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

* package: gcc-4.9.3.p1
log file: /home/w/sage-7.4/logs/pkgs/gcc-4.9.3.p1.log

---

Full log attached.

To see exactly the same thing on any x86 docker-capable machine, just
use docker to run the ubuntu:16.10 image, then

apt-get update; apt-get install dpkg-dev m4 flex bison python perl

adduser sage

su - sage

wget http://files.sagemath.org/src/sage-7.4.tar.gz

extract and make.

-- William

On Mon, Oct 31, 2016 at 11:23 AM, Thomas Hunter <thunter1@swarthmore.edu> wrote:
> (I'm new to posting in these groups so I apologize in advance if I am
> misplacing my query.)
>
> I'd also love to know how to work around this. If the thread moved
> elsewhere, please post a pointer here.
>
> Many thanks,
> Thomas
>
> On Thursday, October 20, 2016 at 11:21:52 AM UTC-4, Herbert Eisenbeis wrote:
>>
>> In deed, the GCC hardening in Ubuntu 16.10 is responsible for the make
>> error.
>> Two questions:
>>
>> How can I configure make to circumvent the error in building flint?
>> Are some other sage packages affected by GCC hardening?
>>
>> Herbert
>>
>>
>> Am Donnerstag, 20. Oktober 2016 14:40:13 UTC+2 schrieb Jeroen Demeyer:
>>>
>>> The problem seems to be that your GCC was configured with
>>> --enable-default-pie and FLINT does not like that. More information at
>>>
>>> https://wiki.ubuntu.com/SecurityTeam/PIE
>
> --
> You received this message because you are subscribed to the Google Groups
> "sage-devel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to sage-devel+unsubscribe@googlegroups.com.
> To post to this group, send email to sage-devel@googlegroups.com.
> Visit this group at https://groups.google.com/group/sage-devel.
> For more options, visit https://groups.google.com/d/optout.



--
William (http://wstein.org)

--
You received this message because you are subscribed to the Google Groups "sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscribe@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:09:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง

--
เขียนโดย computer ถึง computer เวลา 10/31/2559 01:10:00 หลังเที่ยง